TEHDIT ÖZETI: KRITIK APACHE STRUTS GÜVENLIK AÇIĞI CVE-2018-11776 HAKKINDA BILGILER

1.002 people reacted 0 5 min. read
Christopher Budd

By

Category: Uncategorized @tr

Tags:

This post is also available in: English (İngilizce) 繁體中文 (Klasik Çince) Deutsch (Almanca) 한국어 (Kore dili) Nederlands (Hollandaca) Español (İspanyolca) Italiano (İtalyanca)

Duruma Genel Bakış

Apache Vakfı 22 Ağustos 2018 günü, 2.3’ten 2.3.34’e ve 2.5’ten 2.5.16’ya kadar olan Apache Struts sürümlerini etkileyen uzaktan kod yürütme güvenlik açığı CVE-2018-1176 için kritik bir güvenlik güncellemesi  yayınladı. Apache Vakfı herkesi güvenlik güncellemelerini bir an önce uygulamaya teşvik etti.

Bu blog, kuruluşların güvenlik açığı risklerini değerlendirmelerine yardımcı olacak bilgiler sunmakta ve Palo Alto Networks müşterilerini, karşılaştıkları riskleri güvenlik güncellemelerini uygulayana kadar azaltmalarına yardımcı olacak koruma olanakları hakkında bilgilendirmektedir. 24 Ağustos 20148 günü yayınlanan en son güvenlik açığı imzalarını yükleyen Palo Alto Networks müşterileri koruma altındadır.

 

Güvenlik Açığı Bilgileri

Apache Vakfı’na ve güvenlik araştırmacısı Man Yue Mo’ya göre, bu güvenlik açığı, Apache Struts’ın savunmasız sürümünün çalıştığı bir sunucuda uzaktan kod yürütmeyi etkinleştirebilir. Saldırı yöntemi, savunmasız sisteme gönderilmiş, özel olarak oluşturulmuş bir URL yoluyla gerçekleşir. Çoğu vakada bu durum, güvenlik açığını istismar etmek için kimlik doğrulaması gerekmediği anlamına gelmektedir.

Başarılı bir saldırı, Struts’ın kullanmakta olduğu güvenlik bağlamında kod çalıştırır. Bazı vakalarda, bu durum sistemin tümüyle tehlikeye girmesine yol açabilir.

Ancak, varsayılan konfigürasyonlarda güvenlik açığının istismar edilebilir olmadığını akılda tutmak önemlidir. Saldırıya açık bir sistem için aşağıdaki iki koşul karşılanmalıdır:

Struts konfigürasyonunda alwaysSelectFullNamespace bayrağı “doğru” olarak ayarlanır. (Not: Uygulamanız popüler Struts Convention eklentisini kullanıyorsa, bayrak eklenti tarafından varsayılan olarak “doğru” olarak ayarlanır.

Struts uygulaması, bir ad alanı belirtilmeden veya bir joker karakter ad alanıyla konfigüre edilmiş “eylemler” kullanır. Bu koşul, Struts konfigürasyon dosyasında belirtilmiş eylemlere ve ad alanlarına uygulanır. NOT: Uygulamanız popüler Struts Convention eklentisini kullanıyorsa, bu koşul Java kodunda belirtilen eylemlere ve ad alanlarına da uygulanır.

Struts uygulamanız bu koşulların ikisini de karşılamıyorsa, uygulamanız hâlâ saldırıya açık olabilir ama  CVE-2018-11776 yoluyla istismar edilmez (şimdilik).

Özellikle, uygulamanız popüler Struts Convention eklentisini kullanıyorsa, o eklentiyi kullanmayan diğer Struts uygulamalarına kıyasla istismar edilebilme riskinizi potansiyel olarak artırabilir.

 

Tehdit Ortamı Bilgisi

Güvenlik açığı, 22 Ağustos’ta bu tehdide yönelik güvenlik güncellemeleriyle birlikte açıklandı. Güvenlik açığıyla ve nasıl istismar edileceğiyle ilgili ayrıntılı bilgi mevcuttur. Ayrıca, kullanılabilir kavram kanıtı (PoC) kodu da bulunmaktadır. Yukarıda belirtildiği gibi, PoC yalnızca saldırıya açık ve iki istismar edilebilme koşulunu da karşılayan sistemlere karşı işe yarar.

Daha önceki bir kritik Struts güvenlik açığına geçen yıl, güvenlik güncellemesi ve güvenlik açığı bilgisinin yayınlanmasından yalnızca üç gün sonra etkin olarak saldırıldığını bildirenler olmuştur.

Şu anda bilinen etkin bir saldırı yoktur ve güvenlik açığının istismar edilebilmesi için varsayılan olmayan iki koşulun karşılanması gerektiği koşulu, farklı bir tehdit ortamına doğru gitmektedir.

Ancak etkin PoC’nin kullanılabilir olmasıyla, yakın gelecekte bu güvenlik açığının etkin istismarı yoksa, en az yoklamayı bekleyebiliriz.

Kuruluşlar, dört şeye yama uygulayana kadar olası saldırı için risk değerlendirmelerine odaklanmalıdır:

  • Struts Convention eklentisini kullanıyorlar mı?
  • İstismar için gerekli iki koşulu da karşılıyorlar mı?
  • Herhangi bir silahlandırma veya mevcut PoC’yi kullanan saldırılara dair belirti
  • Etkisiz hale getirilen yeni PoC geliştirmeleri veya saldırılar, istismar edilebilirlik için gerekli iki koşulu karşılıyor mu?

 

Palo Alto Networks Müşterileri İçin Rehberlik ve Koruma Olanakları

Apache Struts’ın saldırıya açık sürümlerini kullanan tüm kuruluşlar güvenlik güncellemelerini bir an önce yüklemelidir.

Kuruluşlar, güvenlik güncellemelerinin planlanmasını ve yüklenmesini güvenlik politikalarına ve mevcut bilgilere dayalı olarak önceliklendirmelidir.

24 Ağustos 2018 günü yayınlanan ve Kimlik 33948 Ad: Apache Struts 2 Uzaktan Kod Yürütme Güvenlik Açığı’nı barındıran içerik yayın sürümü 8057’deki güvenlik açığı imzalarını yükleyen Palo Alto Networks müşterileri, bu güvenlik açığına dair bilinen istismarlara karşı koruma altındadır.

Müşterilerimiz güvenlik güncellemesini yine de yukarıda önerildiği gibi yüklemelidir ancak ek koruma için en son güvenlik açığı imzasını da derhal yüklemelidirler. Müşterilerimiz bu ek korumayı, güvenlik ve güvenlik güncellemesine ilişkin kararlarının ve güvenlik açığı ile tehdit ortamı değerlendirmelerinin bir parçası olarak kullanmalıdır.

Her zamanki gibi, durumu yakından izliyoruz ve kullanıma girer girmez ek ayrıntılar sunacağız.

Got something to say?